
B.Tech–ANE 

AIRCRAFTPERFORMANCE 

R-22 

 
 

 
(AUTONOMOUSINSTITUTION–UGC, GOVT. OF INDIA) 

 
 
 
 
 
 
 
 
 
 
 

 

Department of AERONAUTICAL 
ENGINEERING 

 
 
 
 

 
COMPUTATIONAL AERODYNAMICS LAB 

 

 
Prepared by: 

E Dinesh Guptha/M Pramod 

Assistant Professor 
Department of ANE  

MRCETCAMPUS 



R-22 

 

 
COMPUTATIONAL AERODYNAMICS 

 

LABORATORY MANUAL 

B.TECH (R-22 Regulation) 

(III YEAR – I SEM) 

(2025-26) 
 

 

 

DEPARTMENT AERONAUTCAL ENGINEERING 
 

 

 
MALLA REDDY COLLEGE OF ENGINEERING & TECHNOLOGY 

(Autonomous Institution–UGC, Govt. of India) 
Recognized under2 (f) and 12(B) of UGC ACT 1956 

(Affiliated to JNTU H, Hyderabad, Approved by AICTE -Accredited by NBA & NAAC–‘A’ Grade- ISO9001:2015Certified) Maisammaguda, 
Dhulapally (Post Via. Hakimpet), Secunderabad – 500100, Telangana State, India 



CA LAB MANUAL 
Dept of ANE, MRCET 

iii 

 

 

 

 

DEPARTMENT OF AERONAUTICAL ENGINEERING 

 

VISION 

Department of Aeronautical Engineering aims to be indispensable source in Aeronautical Engineering 

which has a zeal to provide the value driven platform for the students to acquire knowledge and 

empower themselves to shoulder higher responsibility in building a strong nation. 

MISSION 

(a) The primary mission of the department is to promote engineering education and research. 

(b) To strive consistently to provide quality education, keeping in pace with time and technology. 

(c) Department passions to integrate the intellectual, spiritual, ethical and social development of the 

students for shaping them into dynamic engineers. 

 

QUALITY POLICY 

Impart up-to date knowledge to the students in Aeronautical area to make them quality engineers. 

Make the students experience the applications on quality equipment and tools. Provide systems, 

resources, and training opportunities to achieve continuous improvement. Maintain global standards 

in education, training, and services. 



CA LAB MANUAL 
Dept of ANE, MRCET 

iv 

 

 

 
PROGRAMME EDUCATIONAL OBJECTIVES (PEO’S) 

 

 

PEO1: PROFESSIONALISM & CITIZENSHIP 

To create and sustain a community of learning in which students acquire knowledge and learn to 

apply it professionally with due consideration for ethical, ecological and economic issues. 

PEO2: TECHNICAL ACCOMPLISHMENTS 

To provide knowledge based services to satisfy the needs of society and the industry by 

providing hands on experience in various technologies in core field. 

PEO3: INVENTION, INNOVATION AND CREATIVITY 

To make the students to design, experiment, analyze, interpret in the core field with the help of 

other multi disciplinary concepts wherever applicable. 

PEO4: PROFESSIONAL DEVELOPMENT 

To educate the students to disseminate research findings with good soft skills and become a 

successful entrepreneur. 

PEO5: HUMAN RESOURCE DEVELOPMENT 

To graduate the students in building national capabilities in technology, education and research. 



CA LAB MANUAL 
Dept of ANE, MRCET 

v 

 

 

PROGRAM SPECIFIC OBJECTIVES (PSO’s) 

 
1. To mould students to become a professional with all necessary skills, personality and sound 

knowledge in basic and advance technological areas. 

2. To promote understanding of concepts and develop ability in design manufacture and maintenance 

of aircraft, aerospace vehicles and associated equipment and develop application capability of the 

concepts sciences to engineering design and processes. 

3. Understanding the current scenario in the field of aeronautics and acquire ability to apply 

knowledge of engineering, science and mathematics to design and conduct experiments in the 

field of Aeronautical Engineering. 

4. To develop leadership skills in our students necessary to shape the social, intellectual, business 

and technical worlds. 
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PROGRAM OBJECTIVES (PO’S) 

 

 

Engineering Graduates will be able to: 
1. Engineering knowledge: Apply the knowledge of mathematics, science, engineering 

fundamentals, and an engineering specialization to the solution of complex engineering 

problems. 

2. Problem analysis: Identify, formulate, review research literature, and analyze complex 

engineering problems reaching substantiated conclusions using first principles of 

mathematics, natural sciences, and engineering sciences. 

3. Design / development of solutions: Design solutions for complex engineering problems 

and design system components or processes that meet the specified needs with appropriate 

consideration for the public health and safety, and the cultural, societal, and environmental 

considerations. 

4. Conduct investigations of complex problems: Use research-based knowledge and 

research methods including design of experiments, analysis and interpretation of data, and 

synthesis of the information to provide valid conclusions. 

5. Modern tool usage: Create, select, and apply appropriate techniques, resources, and 

modern engineering and IT tools including prediction and modeling to complex 

engineering activities with an understanding of the limitations. 

6. The engineer and society: Apply reasoning informed by the contextual knowledge to 

assess societal, health, safety, legal and cultural issues and the consequent responsibilities 

relevant to the professional engineering practice. 

7. Environment and sustainability: Understand the impact of the professional engineering 

solutions in societal and environmental contexts, and demonstrate the knowledge of, and 

need for sustainable development. 

8. Ethics: Apply ethical principles and commit to professional ethics and responsibilities and 

norms of the engineering practice. 

9. Individual and team work: Function effectively as an individual, and as a member or 

leader in diverse teams, and in multidisciplinary settings. 

10. Communication: Communicate effectively on complex engineering activities with the 

engineering community and with society at large, such as, being able to comprehend and 

write effective reports and design documentation, make effective presentations, and give 

and receive clear instructions. 

11. Project management and finance: Demonstrate knowledge and understanding of the 

engineering and management principles and apply these to one’s own work, as a member 

and leader in a team, to manage projects and in multi disciplinary environments. 

12. Life- long learning: Recognize the need for, and have the preparation and ability to engage 

in independent and life-long learning in the broadest context of technological change. 
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MALLA REDDY COLLEGE OF ENGINEERING & TECHNOLOGY 

 

IV Year B. Tech, ANE-I Sem 

 

(R18A2188)COMPUTATIONAL AERODYNAMICS LAB 

L T/P/D C 

0 -/3/- 1.5 

Objectives: 

• To develop an understanding for the major theories, approaches and methodologies used in 
CFD. 

• To build up the skills in the actual implementation of CFD methods (e.g. boundary 
conditions, turbulence modeling etc.) in using commercial CFD codes. 

• To gain experience in the application of CFD analysis to real engineering designs. 

LIST OF EXPERIMENTS: 
1. Numerical simulation of Flow over an airfoil using commercial software 
2. Numerical simulation of Supersonic flow over a wedge using commercial Software 
3. Numerical simulation of Flat plate boundary layer using commercial software 
4. Numerical simulation of Laminar flow through pipe using commercial software 
5. Numerical simulation of Flow past cylinder using commercial software 
6. Numerical simulation of flow through nozzle using commercial software 
7. Numerical simulation of flow over wing using commercial software 
8. Numerical simulation of combustion using commercial software 
9. Solution for the one dimensional wave equations using explicit method of lax using finite 

a. Difference method (code development) 
10. Solution for the one dimensional heat conduction equation using explicit method using finite 

difference method (code development) 
11. Generation of the Algebraic Grid (code development) 
12. Generation of the Elliptic Grids (code development) 

Note: Any 10 Experiments can be conducted. 
Equipment Needed: 

Computers: Core 2 duo processor with 1 GB RAM 
Softwares: Matlab or scilab and Ansys or equivalent softwares 

Reference Books: 
• ANSYS FLUENT and CFX Tutorials 

• MATLAB an Introduction with Applications Fifth Edition AMOS GILAT by WILEY 
Publications 

• Programming in SCI lab by VINU V DAS New Age International Publications 

Outcomes: 
• Students will develop a better intuition of Aerodynamics more quickly than is possible with 

traditional analytical approaches. 

• Ability to undertake problem identification, formulation and solution and apply knowledge of 
basic science and engineering fundamentals. 

• Developing a geometrical model of the flow, applying appropriate boundary conditions, 
specifying solution parameters, and visualizing and analyzing the results. 
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CODE OF CONDUCT FOR THE LABORATORIES 

 
➢ All students must observe the Dress Code while in the laboratory. 

➢ Sandals or open-toed shoes are NOT allowed. 

➢ Foods, drinks and smoking are NOT allowed. 

➢ All bags must be left at the indicated place. 

➢ The lab timetable must be strictly followed. 

➢ Be PUNCTUAL for your laboratory session. 

➢ Program must be executed within the given time. 

➢ Noise must be kept to a minimum. 

➢ Workspace must be kept clean and tidy at all time. 

➢ Handle the systems and interfacing kits with care. 

➢ All students are liable for any damage to the accessories due to their own negligence. 

➢ All interfacing kits connecting cables must be RETURNED if you taken from the lab supervisor. 

➢ Students are strictly PROHIBITED from taking out any items from the laboratory. 

➢ Students are NOT allowed to work alone in the laboratory without the Lab Supervisor 

➢ USB Ports have been disabled if you want to use USB drive consult lab supervisor. 

➢ Report immediately to the Lab Supervisor if any malfunction of the accessories, is there. 

 

Before leaving the lab 

 

 

➢ Place the chairs properly. 

➢ Turn off the system properly 

➢ Turn off the monitor. 

➢ Please check the laboratory notice board regularly for updates. 
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1. FLOW OVER AN AEROFOIL AIM: To simulate flow over NACA 0012 

airfoil Problem description: 

Consider air flowing over NACA 0012 airfoil. The free stream velocity is 

40 m/s . Assume standard sea-level values for the free stream properties: 

Pressure = 

101,325 Pa 

Density = 

1.2250 kg/m3 

Temperature = 

288.16 K 

Kinematic viscosity v = 1.4607e-5 m2/s 
Steps Involved In ICEM 

CFD: Creation of Geometry in ICEM CFD: 

 
➢ Importing the Aerofoil coordinates 

File→Import Geometry→Formatted point data→Select the file of 

aerofoil coordinates which is in DAT format→ok. Now the 

coordinates will be displayed. 

➢ Geometry→Create/modify curve→From points→Select above 

points and leave last 2 points→middle click 

➢ Similarly on bottom side 

➢ Join the end points of the curves 
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1) Creation of parts: 
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➢ Parts in the tree→Right 

click→Create part→ Select Upper 

curve: Suction 

Select Lower curve: 

Pressure 3rd Line: TE 

2) Creation of Domain: 
➢ Create points (-1,1),(-1,-1),(2,1),(2,-1) 

➢ Join these points 

➢ Create parts as Inlet, Outlet, Top & Bottom 

➢ Geometry→Create/Modify surface→Simple surface→Select all the 

lines of domain→ok 

➢ Create the new part as: Surface 

3) Saving the Geometry: 
➢ File→Change working directory→Choose the folder 

➢ File→Geometry→Save Geometry as→Give the name. 

4) Creation of Blocking and Association: 
➢ Blocking→Create block→Initialize blocks→Type as:2D Planar→ok 

➢ Associate→Associate vertex to point→Select a vertex and a 

point→Apply→ Similarly associate remaining 3 vertices to points 

➢ Associate→Associate edge to curve→Select a edge and a curve →Apply→ 

Similarly associate remaining 3 edges to curves 

➢ Split block→Select the edges→Create the blocks as shown in figure 

 

 

➢ Split block→O grid →Select edges→Select last 2 edges in 

the middle row→ok→Select blocks→Select last 2 blocks in 
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the middle row→ok 
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Thus the O grid has been generated as shown in below fig. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

➢ Associate →Associate vertex to point→Select the vertex of the O grid and the 

2nd point on the upper curve(suction) →ok 

➢ Similarly associate remaining 3 vertices of the O grid to the points on the 

aerofoil as shown in the below fig. 
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➢ Associate→Associate edge to curve→Select the 3 edges of block 

which is inside of the aerofoil and select the suction & pressure 

curves→ok Similarly associate the TE edge to TE curve. 

➢ Delete block→Select the block inside the aerofoil→ok 

5) Generation of Mesh: 
➢ Pre-mesh parameters→Edge parameters→Switch ON the Copy 

Parameters→ Select the edges and give desired no. of nodes→ok 

➢ Switch ON Pre-mesh in the tree→click yes to compute the meshing 

➢ Pre-mesh→Right click→Convert to unstructured mesh 

Now the required mesh has been generated as shown in below fig. 
 

 

6) Saving the Project: 
➢ File→Save Project as→Give the name. 

7) Writing output file: 
➢ Output→Select solver→Output solver as: Fluent_V6→Common 

Structural solver as: ANSYS→ok 

➢ Write input→Click NO→Open the file→Click 2D→ok 
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Steps Involved in Fluent: 

 

8) Importing the mesh file: 
➢ File→Read→mesh→Choose the output file written in 

ICEM CFD Now the mesh has imported into the fluent 

solver. 

9) Problem setup: 
➢ General→Type as: Pressure based 

➢ Models→Energy ON→ inviscid 

➢ Materials→Air 

➢ Cell zone conditions→Type as: fluid→ok 

➢ Boundary conditions→Select inlet→Edit→Give velocity 

magnitude as: 40 m/s. 

➢ Boundary conditions→Select outlet→Edit→Give gauge pressure as: 0 Pa 

➢ Monitors →Drag and Lift → select suction, pressure, TE parts→plot. 

10) Solution: 
➢ Select the required monitors 

➢ Solution initialization→Compute from: inlet→Initialize 

➢ Run calculations→Enter the no. of iterations as: 1000→Calculate 

11) Results: 
➢ Graphics and animations→select the required flow parameters in the 

contours and vectors. 

The results are shown below as: 
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Exercise Problems: 

1.1 Evaluate aerodynamic characteristics of aerofoil at 15 degrees angle of attack. 

1.2 Perform the grid independence study over airfoil. 
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2. SUPERSONIC FLOW OVER A WEDGE 

 
Problem description: 

 
Consider air flowing over wedge. The free stream Mach number is 3 and the angle of 

attack is 5°. Assume standard sea-level values for the free stream properties: 

Pressure =101,325Pa 

Density =1.2250kg/m3 

Temperature =288.16K 

Kinematic viscosity v = 1.4607e-5 m2/s 

 

Steps Involved In ICEM CFD: 

 

1) Creation of Geometry in ICEM CFD: 
 

a. Geometry→Create point→Explicit coordinates→Enter the coordinates as 

given in table shown: 

 

X 0 0 0.5 1.5 1.5 0.5 

Y 0 1.259 1.259 1.259 0268 0 

Z 0 0 0 0 0 0 

Geometry→Create/modify curve→From points→Select any 2 

points→ok→Similarly create the curves to all points 

b. Geometry→Create/Modify surface→Simple surface→Select all the lines of 

domain→ok 

 



Dept of ANE CA Lab Manual 

MRCET UGC Autonomous Page 11 

 

 

 

 

2) Creation of parts: 
a. Parts in the tree→Right click→Create part→ 

Select Left curve: Inlet 

Select Right curve: Outlet 

Select Top curve: Top 

Select inclined curve: Wedge 

Select bottom curve: Front_wedge 

3) Saving the Geometry: 
a. File→Change working directory→Choose the folder 

b. File→Geometry→Save Geometry as→Give the name. 

4) Creation of Blocking and Association: 
a. Blocking→Create block→Initialize blocks→Type as:2D Planar→ok 

b. Associate→Associate vertex to point→Select a vertex and a point→Apply→ 

Similarly associate remaining 3 vertices to points 

c. Associate→Associate edge to curve→Select a edge and a curve →Apply→ 

Similarly associate remaining 3 edges to 5 curves 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

5) Generation of Mesh: 
a. Pre-mesh parameters→Edge parameters→Switch ON the Copy Parameters→ 

Select the Horizontal edge and give no. of nodes as: 100→ok 

b. Pre-mesh parameters→Edge parameters→Switch ON the Copy Parameters→ 

Select the Vertical edge and give no. of nodes as: 100→Spacing as: 

0.001→Ratio as: 1.1→ok 
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c. Switch ON Pre-mesh in the tree→click yes to compute the meshing 

d. Pre-mesh→Right click→Convert to unstructured mesh 

Now the required mesh has been generated as shown in below fig: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Structural 

 

 

 

 

 

 

 

 

8) Importing the mesh file: 
a. File→Read→mesh→Choose the output file written in ICEM CFD 

Now the mesh has imported into the fluent solver. 

9) Problem setup: 
a. General→Type as: Density based 

b. Models→Energy ON→Select Viscous-laminar→Edit→Set model as: k- 

omega(2 equ) 

c. Materials→Air→Create/Edit→Set density as: Ideal-gas→Set viscosity as: 

Sutherland→Change 

d. Cell zone conditions→Type as: fluid→Set operating conditions→Set 

operating pressure as: 0Pa 

Saving the Project: 

a. File→Save Project as→Give the name. 

Writing output file: 

a. Output→Select solver→Output solver as: Fluent_V6→Common 

solver as: ANSYS→ok 

b. Write input→Click NO→Open the file→Click 2D→ok 

Steps Involved in Fluent: 
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e. Boundary conditions→Select inlet→Give type as: pressure-far- 

field→Edit→Give Gauge pressure as: 101325Pa→Set Mach as: 3→ok 

f. Boundary conditions→Select outlet→Edit→Give gauge pressure as: 0Pa 

 

 

10) Solution: 
a. Select Solution Controls→Set Courant number as: 1 

b. Select the required monitors 

c. Solution initialization→Compute from: inlet→Initialize 

d. Run calculations→Enter the no. of iterations as: 1000→Calculate 

11) Results: 
a. Graphics and animations→Select the required flow parameters in the contours. 

The results are shown below as: 
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Exercise Problems: 

2.1 Evaluate flow properties across oblique shock of wedge at 15 degrees angle of attack. 

2.2 Compare the results with analytical formulas. 
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3. FLOW OVER A FLAT PLATE 

Aim: To study the characteristics of flow over a flat plate 

Description: Consider a plate of 1m and the flow of air is 0.00133 m/s. The plate is an 

stationary solid wall having no slip as its boundary condition. 

Procedure: 
 

 Geometry→ create point→ explicit coordinates→ 1(0,0,0), 2(1,0,0), 3(1,1,0) and 

4(0,1,0) → ok 

 Create/modify curve→ select 2 points→ middle click 

 Select all points to make a rectangle 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Create/modify surface→ select all the lines→ surface is created 

 Create part→ name inlet→ select the left edge→ middle click 

 Similarly create outlet, top and bottom 

 Switch off points and curves→ create part→ name surf→ click on surface→ ok 

 Blocking→ create block→ select entities→ click spectacles→ middle click→ switch 

on points and curves 

 Go to association→ associate vertex→ select the point→ double click on the point 

 Associate→ edge to curve→ select the edge→ ok→ again select the edge→ ok 

 Similarly for the remaining edges 

 Premesh parameters→ edge parameters→ select any edge→ click on copy 

parameters→ nodes-60, spacing-0.01, ratio-1.1→ ok 

 Blocking tree→ premesh→ right click→ convert structured to unstructured mesh 
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 Change the working directory 

 output→ output solver→ fluent V6→ common-ansys→ ok 

FLUENT: 

 Folder→ general→ mesh→ fluent mesh→ ok 

 Click on check→ done 

 Models→ viscous laminar→ materials→ air 

 Cell zone conditions→ solid→ ok 

 Boundary conditions→ bottom→ edit→ stationary wall→ ok, inlet→ velocity- 

0.00133→ ok, outlet→ guage pressure-0→ ok, top→ edit→ moving wall→ ok 

 Dynamic mesh→ solution→ solution method-simple, solution controls- 

0.3,1,0.3→ ok 

 Monitor initializer→ compute from inlet→ x=0.00133→ initialize 

 Calculation activities→ no of iterations-200→ run calculations→ click on 

calculate→ ok 

  Results→ graphics and animations→ contour→ set up→ display options→ 

filled→ display 

Contour→ velocity→ display 
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8.1 Find out the effect of viscosity of water on flat plate. 

8.2 Find the material of the plate on velocity profile. 
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4. LAMINAR FLOW THROUGH PIPE 

AIM: To study characteristics of laminar flow through a pipe. 

DESCRIPTION: Consider a pipe of radius 0.05 and 1 mt length. The freestream velocity 

considered is 40m/s. 

STEPS INVOLVED: 

1) Create A Geometry: 
a) Create a point: Geometry →create point →explicit coordinates→(X, Y, Z) = 

(0, 0, 0) →apply→(X, Y, Z) = (1, 0, 0) →ok. 

 

b) Create a pipe: Geometry→Create/modify surfaces→Standard shapes→ 

cylinder→radius1=radius2 = 0.05→select the 2 points →ok 
 

2) Generation of parts: 

➢ Part →create part→inlet→select inlet→ok. 

 

➢ Part →create part →outlet →select outlet →ok. 

 

➢ Part →create part →pipe →select pipe without inlet and outlet →ok. 

 

3) Generation of blocking: 
 

➢ Blocking →create block →solid →select pipe element with inlet and outlet→ 

apply→ok. 

➢ Blocking →associate →edge to curve →select the 4 edges of the blocking at 

inlet →apply →select the inlet curve→ok. 
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➢ Repeat the above steps to the remaining edges also and then apply. 

 

➢ Blocking →pre-mesh →compute. 

 

 

➢ Blocking→associate →edge to curve→select the 4 edges of the blocking at 

outlet → apply→select the outlet curve→ok. 

➢ Associate→faces to surface→select inlet face → apply →select as 

inlet→accept →ok. 

 

➢ Associate → faces to surface → select outlet face → apply → select as outlet 

→accept →ok. 

➢ Associate →face to surface → select pipe faces → apply → select as pipe → 

accept → 

➢ Blocking →split block →O grid block →select the 2 faces (inlet & outlet) 

→apply →ok. 

 

4) Generation of Meshing: 

➢ Blocking → pre-mesh parameters → edge parameters → switch on the copy 

parameters →select 1 edge →give no. of nodes =20→ok. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

➢ Blocking →pre-mesh →convert to unstructured mesh. 

 

5) Generation of Solver file : 

➢ Output→select solver→ansys.cfx→ANSYS→ok. 

➢ Output →write input →done →check the file is saved folder →ok. 



Dept of ANE CA Lab Manual 

MRCET UGC Autonomous Page 20 

 

 

 

 

 

6) Solution in CFX Solver: 

➢ Start →programs →ANSYS →fluid dynamics →CFX →ok. 

 

➢ Change the working directory (where ICEM CFD mesh file was 

saved)→Click on CFX-PRE. 

 

7) CFX-PRE: 

➢ File→new case→general→ok. 

➢ File→import→mesh→select the meshed filed→ok. 

 

➢ Boundary→Boundary1→Boundary type as: inlet→location as: 

inlet→boundary conditions as: velocity=40m/s→ok. 

➢ Boundary→Boundary2→boundary type as: outlet→location as: 

outlet→boundary conditions as: static pressure=0→ok. 

 

➢ Boundary→Boundary3→boundary type as: wall→location as: 

pipe→boundary conditions as: no slip condition, smooth wall→ok. 

➢ Domain→basic settings→location as: solid→domain type as: fluid 

domain→material as: air→ok. 

 

➢ Solver control→basic settings→ max.itterationsas:1000→residual target as: 

0.000000001→ok. 

➢ Write solver input file→give the name of the file→ok. 
 

 



Dept of ANE CA Lab Manual 

MRCET UGC Autonomous Page 21 

 

 

 

 

8) CFX-Solver Manager: 

➢ File→Define run→Solver input file→Select the file→Start run. 

 
9) CFD POST 

➢ Select →Location →Plane →XY Plane → Apply 

➢ Contours →Location → plane→Variable→ Velocityand pressure →Apply. 

Incoming flow through inlet 

 

 

 

pressure contour 
 

 

 

Exercise problems 

9.1 Find out the effect convergent section on velocity. 

9.2 Find the minor losses in a bend pipe. 
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5. FLOW PAST OVER A CYLINDER 

AIM : To study the characteristics of flow over a cylinder. 

DESCRIPTION: Consider a cyclinder of 3m radius and 6m height. The free stream velocity 

considered 20m/s. the properties of air is ρ=1.18kg/m3. 

PROCEDURE: 

CREATION OF GEOMETRY: 

 Geometry → create point → explicit coordinates → (0,0,0) 

 Geometry → create surface → standard shapes → box → (36 18 18) → apply → 

solid simple display 

 Geometry → create point → based on 2 locations → select 2 diagonal points of face 

 Geometry → transform geometry → copy → select point → Z-offset =6 → apply → 

z-offset=12→ ok. 

  Geometry → surfaces → standard shapes → cylinder r1=3.r2=3 → select 2 points of 

cylinder → apply 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

CREATION OF PARTS AND MESH GENERATION: 

  parts→ create parts → ( part name) → select entities → middle click (create parts 

according to the problem i.e. inlet, outlet, cylinder & free slip wall) 

 geometry → solid → part(mp) → select two points lying outside the cylinder → apply. 

 Mesh → mesh parameters → cylinder -1.5, inlet-2.5, outlet-2.5, slipfree-0.7 Mesh → 

 global mesh setup → global mesh size → max element size (3) → apply. 

Mesh → compute mesh → compute. 
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 Output → outpur solver- ANSYS CFX → common solver → ANSYS →APPLY 

  WRITE INPUT → OK 

PROBLEM DEFINITION IN CFX-PRE: 
 CFX → change the working directory → cfx-pre File → new case 

 → general → apply. 

 Mesh → import mesh → ICEM CFD → OK domain → fluid 

 domain → air at 25c 

 Boundary → inlet → domain: inlet → velocity=40m/s. 

 Boundary → outlet → domain outlet → static pressure=0 Pa → apply Boundary → freeslip 

 → domain free slip → free slip → ok. 

 Solver settings → 1000 iterations → apply. Define solver → 

 solver input file → ok 
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Solve: 

• CFD solver → open cfx file → define run → ok 

Post processing: 
CFD post → load result → 

select .res file Location → 

plane → Z=9 apply 

Contours → domain: plane1 → velocity → local → conservative → 

apply. 

 

 Contours → domain: plane1 → pressure→ local → conservative → 

apply. 
 

 Stream lines → domain : plane 1 → local → conservative → apply. 

 

Exercise problems 
5.1 Find out the effect of supersonic flow over cylinder . 

5.2 Find the minor losses in a bend pipe 
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6. Numerical simulation of flow through CD Nozzle 

Aim: Consider the nozzle having a cross sectional area A varies with axial distance from the 

throat, according to the formula A = 0.1+X2; where X varies from -0.5<X<0.5. 
Stagnation pressure Po = 101325 pa; stagnation temperature To = 300K; 

 

Software: ICEM and CFX 

 

Procedure: 

Pre processing: 
 

1. Create geometry in ICEM 

• Create the vertex data of Nozzle contour variation along axis line with vertices 

(-0.5, 0) and (0.5, 0) and A = 0.1+X2 in excel sheet. 

• Import vertex data into ICEM by creating .dat file. 

• Create edges by create/modify curves and face by create/modify faces of 

nozzle using geometry function tab. 

• Create body point. 

• Create parts inlet, outlet and wall. 

 

 

2. Mesh geometry: 
• Click Mesh Function tab 

• Give global mesh parameters in global mesh setup like element scale factor and 

element max size. 

• Create partmesh setup for inlet, outlet and wall. 

• Compute mesh – volume mesh – mesh type – select geometry – compute. 

• Edit mesh – check mesh – quality mesh – smooth mesh. 

 

 

3. Export mesh 
• Output – output to cfx – save project – output type – output scale factor - .msh 

file created. 

 

 
4. CFX: 

• CFX Pre – New file – general. 

• Mesh - Import mesh – ICEM CFD – open .msh file. 
 

 

 

Domain - Default Domain Modified 
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Type Fluid  

Location FLUID 

Materials 

Air Ideal Gas 

Fluid Definition Material Library 

Morphology Continuous Fluid 

Settings 

Buoyancy Model Non Buoyant 

Domain Motion Stationary 

Reference Pressure 1.0000e+00 [atm] 

Heat Transfer Model Isothermal 

Fluid Temperature 2.5000e+01 [C] 

Turbulence Model k epsilon 

Turbulent Wall 

Functions 
Scalable 

Domain Boundaries 

 

 

 

 

 

 

 

 

 

 

 

Default Domain 

Modified 

Boundary - inlet 

Type INLET 

Location IN 

Settings 

Flow Regime Subsonic 

Mass And Momentum Normal Speed 

Normal Speed 2.8000e+02 [m s^-1] 

Turbulence 
Medium Intensity and Eddy Viscosity 

Ratio 

Boundary - outlet 

Type OUTLET 

Location OUT 

Settings 

Flow Regime Subsonic 

Mass And Momentum Average Static Pressure 

Pressure Profile 

Blend 
5.0000e-02 
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 Relative Pressure 1.0132e+05 [Pa] 

Pressure Averaging Average Over Whole Outlet 

Boundary - WALL 

Type WALL 

Location Wall 

Settings 

Mass And Momentum No Slip Wall 

Wall Roughness Smooth Wall 

5. Solve the problem: 
 

 

• Solver Control – Basic setting 

• Advection scheme 

• Turbulence Numerics 

• Convergence controls 

• Fluid timescale control 

• Convergence criteria 

 

 

POST PROCESSING 

 

6. Analyze results: 
• Create plane 

• Create contour – pressure, mach number 

• Create streamlines 

• Create chart for temperature along nozzle axis. 
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Mach number contour 
 

Pressure contour 



Dept of ANE CA Lab Manual 

MRCET UGC Autonomous Page 29 

 

 

7. Numerical simulation of flow over wing 

Aim: To obtain flow field over a finite rectangular wing with incoming flow conditions 

velocity 120 m/s, Pressure 1 atm and air at 250c. 

 

Software: ICEM and CFX 

 

Procedure: Pre processing: 

 

1. Create geometry in ICEM 
• Import vertex data of airfoil coordinates from File → Import Geometry → 

Formatted point data. 

• Join the points by selecting geomtry tab, Create curve from points. 

• Create a line in Z direction to extrude airfoil. 

• Geometry → Create surface → Curve driven → select driving curve and then 

the remaining lines under the driven curve → Apply. 

• Geometry → Create surface → Simple surface → for upper and lower surface. 

• Create domain for the flow analysis. 

• Delete unwanted surfaces, lines and points. 

• From the model tree → right click on parts → create part → Name 

Inlet – in_1 

Outlet – out_1 

Top – top_1 

Side – sidewall_1 

Bottom – Bot _ 1 

Airfoil – Airfoil_1 

Apply 

• Geometry → Create body → Location → centroid of 2 points → select the two 

diagonally opposite points on the model such that point should not be within 

airfoil→ Apply. 

 

 

2. Mesh geometry: 
• Click Mesh Function tab 

• Give global mesh parameters in global mesh setup like element scale factor and 

element max size = 0.1 → display on → apply. 

• Create partmesh setup for inlet, outlet and wall. 
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• Compute mesh → volume mesh → mesh type → tetra/mixed → create prism 

layers → create hexa-core → mesh method → Robust[octree] → select geometry 

– compute. 

• Edit mesh – check mesh – quality mesh – smooth mesh. 

3. Export mesh 
• Output – output to cfx – save project – output type – output scale factor - .msh 

file created. 

4. CFX: 

• CFX Pre – New file – general. 

• Mesh - Import mesh – ICEM CFD – open .msh file. 

• Default Domain Basic Settings Materials Air at 250c, Reference Pressure 1 atm 

 

Domain - Default Domain Modified  

Type Fluid 

Location FLUID 

Materials 

Air Ideal Gas 

Fluid Definition Material Library 

Morphology Continuous Fluid 

Settings 

Buoyancy Model Non Buoyant 

Domain Motion Stationary 

Reference Pressure 1.0000e+00 [atm] 

Heat Transfer Model Isothermal 

Fluid Temperature 2.5000e+01 [C] 

Turbulence Model SST 

Turbulent Wall Functions Scalable 

Domain Boundaries 

 

 

 

 

Default Domain Modified 

Boundary - inlet 

Type INLET 

Location IN_1 

Settings 

Flow Regime Subsonic 

Mass And Momentum Normal Speed 

Normal Speed 1.3000e+02 [m s^-1] 
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 Turbulence low Intensity = 1% 

 

Boundary - outlet 

Type OUTLET 

Location OUT_1 

Settings 

Flow Regime Subsonic 

Mass And Momentum Average Static Pressure 

Pressure Profile Blend 5.0000e-02 

Relative Pressure 1.0132e+05 [Pa] 

Pressure Averaging Average Over Whole Outlet 

Boundary - WALL 

Type WALL 

 

Location 

Airfoil_1, Top_1, Bot _1 

Settings 

Mass And Momentum No Slip Wall 

Wall Roughness Smooth Wall 

• Click ok and define run to start solution. 

 

POST PROCESSING 

 

5. Analyze results in CFX POST: 
• Create plane 

• Create contour – pressure, mach number 

• Create streamlines 

• Create chart for velocity along plate. 

 

RESULTS: 
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8. Numerical simulation of combustion 

Aim: The problem to be considered is shown schematically in below figure. The 

combustion fuel enters into combustion chamber through the fuel nozzle. Through the 

air inlets air enters from the primary and secondary zones. Both the air and fuel mix in 

the combustion chamber. 

 

 

 

 

Fig 8.1 Problem Description 

Procedure: 
 

 
 

and 
 

 

 

Geometry→ create point→ explicit coordinates→ 1(0,0,0), 2(6,0,0), 3(6,1,0) 

 

4(0,1,0) → ok 

Create/modify curve→ select 2 

points→ middle click Select all 

points to make a rectangle 

• Geometry→ create point→ explicit coordinates→ 1(0,1,0), 2(0,1.25,0), 

3(0,2.75,0) and 

4(0,3,0), 5(0,4.75,0), 6(0,5,0) → ok 

• Select trim using above points to create air and fuel inlets as shown in figure. 

Create/modify surface→ select the entire lines→ surface is 

created Create part→ name air and fuel inlet→ select the left 

edge→ middle click. Similarly create outlet, top and bottom 

Switch off points and curves→ create part→ name surf→ click 

on surface→ ok Blocking→ create block→ select entities→ click 

spectacles→ middle click→ switch on points and curves 

Go to association→ associate vertex→ select the point→ double 
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click on the point Associate→ edge to curve→ select the edge→ 

ok→ again select the edge→ ok Similarly for the remaining 

edges 

Premesh parameters→ edge parameters→ select any edge→ click on copy 

parameters→ nodes-60→ ok 

Blocking tree→ premesh→ right click→ convert structured to 

unstructured mesh 

 Change the working directory 

output→ output solver→ fluent V6→ common-ansys→ ok 

FLUENT: 

Grid 

• Start FLUENT 2d mode 

• Read→ Case and select the mesh file combustionchamber.msh 

• Check the grid using grid→check 

Models 

• Defining the domain 
a) Select 2D from the Space list. 

b) Retain the default settings for the remaining pressure-based solver 

parameters. 

c) Click OK to close the Solver panel. 

• Enable heat transfer by enabling the energy equation. 

• Select the standard k-epsilon turbulence model. 

a) Select k-epsilon from the Model list. The Viscous Model panel will 

expand to provide further options for the k-epsilon model. 

b) Retain the default settings for the k-epsilon model. 

c) Click OK to close the Viscous Model panel. 

• Enabling chemical species transport and reaction 
a) Select Species Transport from the Model list. The Species Model panel will 

expand to provide further options for the Species transport model. 

b) Enable Volumetric in the Reactions group box. 

c) Select n-butane-air from the Mixture Material drop-down list. 

d) Select Eddy-Dissipation from the Turbulence-Chemistry Interaction list. 

e) The eddy-dissipation model computes the rate of reaction under the assumption 

that chemical kinetics are fast compared to the rate at which reactants are mixed 

by turbulent fluctuations (eddies). 
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f) Click OK to close the Species Model panel. 

 

Materials 

• Revise the properties for the mixture materials. 

• The Materials panel will display the mixture material (n-butane-air) that was selected 

in the Species Model panel. 

• The properties for this mixture material have been copied from the FLUENT database 

and will be modified in the following steps. 

a) Retain the default selection of mixture in the Material Type drop-down list. 

b) Click the Edit... button to the right of the Mixture Species drop-down list to 

open the Species panel. 

c) Select constant from the Cp drop-down list and enter 1000 J/kg K for the 

specific heat value. 

d) Scroll down to find the Cp drop-down list and number-entry box. 

e) Click Change/Create to accept the material property settings. 

f) Close the Materials panel. 

 
Boundary Conditions 

• Set the boundary conditions for the air inlet 
(a)  Enter air-inlet for Zone Name. This name is more descriptive for the zone than 

velocity-inlet-8. 

(b) Enter 5 m/s for Velocity Magnitude. 

(c) Select Intensity and Hydraulic Diameter from the Specification Method dropdown 

list in the Turbulence group box. 

(d) Retain the default value of 10% for Turbulent Intensity. 

(e) Enter 1 m for Hydraulic Diameter. 

(f) Click the Thermal tab and type the value of 850 K for Temperature. 

(g) Click the Species tab and enter 0.23 for o2 in the Species Mass Fractions group 

box. 

(h) Click OK to close the Velocity Inlet panel. 

• Set the boundary conditions for the fuel inlet 
(a) Enter fuel-inlet for Zone Name. This name is more descriptive for the zone than 

velocity-inlet-6. 

(b) Enter 80 m/s for the Velocity Magnitude. 
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(c) Select Intensity and Hydraulic Diameter from the Specification Method dropdown 

list in the Turbulence group box. 

(d) Retain the default value of 10% for Turbulent Intensity. 

(e) Enter 0.01 m for Hydraulic Diameter. 

(f) Click the Thermal tab and retain the default value of 300 K for Temperature. 

(g) Click the Species tab and enter 1 for ch4 in the Species Mass Fractions group box. 

(h) Click OK to close the Velocity Inlet panel. 

 

 

• Set the boundary conditions for the exit boundary 
a) Retain the default value of 0 Pa for Gauge Pressure. 

b) Select Intensity and Hydraulic Diameter from the Specification Method dropdown 

list in the Turbulence group box. 

c) Retain the default value of 10% for Turbulent Intensity. 

d) Enter 0.45 m for Backflow Hydraulic Diameter. 

e) Click the Thermal tab and retain the default value of 300 K for Backflow Total 

Temperature. 

f) Click the Species tab and enter 0.23 for O2 in the Species Mass Fractions group 

box. 

g) Click OK to close the Pressure Outlet panel. 

• Set the boundary conditions for the outer wall 
a) Enter outer-wall for Zone Name. 

b) Click the Thermal tab. 

i. Select Temperature from the Thermal Conditions list. 

ii. Retain the default value of 300 K for Temperature. 

c) Click OK to close the Wall panel. 

• Set the boundary conditions for the primary holes 
a) Select the primary holes zone. 

b) Enter 5 m/s for Velocity Magnitude. 

c) Select Intensity and Hydraulic Diameter from the Specification Method dropdown 

list in the Turbulence group box. 

d) Retain the default value of 10% for Turbulent Intensity. 

e) Enter 1 m for Hydraulic Diameter. 

f) Click the Thermal tab and type the value of 850 K for Temperature. 
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g) Click the Species tab and enter 0.23 for o2 in the Species Mass Fractions group 

box. 

h) Click OK to close the Velocity Inlet panel. 

Initial Solution 

• Initialize the field variables. 

a) Select all-zones from the Compute From drop-down list. 

b) Click Init to initialize the variables. 

c) Close the Solution Initialization panel. 

• Set the under-relaxation factors for the species. 
The default under-relaxation parameters in FLUENT are set to high values. For 

a combustion model, it may be necessary to reduce the under-relaxation to stabilize the 

solution. Some experimentation is typically necessary to establish the optimal under-

relaxation. For this analysis, it is sufficient to reduce the species under- relaxation to 

0.95. 

a) Enter 0.95 for each of the species (ch4, O2, co2, and h2o) in the Under- 

Relaxation Factors group box. 

b) Scroll down the Under-Relaxation Factors group box to find the species. 

c) Click OK to close the Solution Controls panel. 

• Save the case file 

• Start the calculation by requesting 500 iterations. 

• Save the case and data files. 

Postprocessing 

• Display Filled contours of mass fraction for C4H10 
a) Select Species... and Mass fraction of ch4 from the Contours of drop-down 

lists. 

b) Click Display. 
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Fig 8.3. Mass Fraction of Butane (C4H10) 

• In a similar manner, display the contours of mass fraction for the specie O2. 
 

 

Fig 8.4 Mass fraction of O2 
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9. SOLUTION FOR THE ONE DIMENSIONAL WAVE EQUATION USING EXPLICIT METHOD 
OF LAX (CODE DEVELOPMENT). 

 
The one dimensional scalar wave equation is given as 

 

This equation represents a linear advection process with wave speed c = constant, 

which is the speed of the travelling wave or the speed of propagation. u(x,t) is 

the signal or wave information. The wave propagates at constant speed to the right 

if c > 0 and to the left if c <1. The spatial domain can vary from -∞ to ∞. Suppose 

the initial conditions are 
 

where  is any function. The exact solution to the wave equation then is 
 

 is called the wave shape of wave form. Travelling or propagation here means 

that the shape of the signal function with respect to x stays constant, however the 

function is translated left or right with time at the speed c. 

Numerical Solution 

Method of descretisation – finite difference form 

Replace the spatial partial derivative with a central difference expression 
 

Where n is the temporal index and j is the spatial 

index. Replace the time derivative with a forward 

difference formula 

 

We then have 

Now let us replace  by an average value between grid points j+1 and j-1 as 
 

Substituting this in equation (1) we get the explicit method of Lax for the 1D scalar 

wave equations as, 



Dept of ANE CA Lab Manual 

MRCET UGC Autonomous Page 39 

 

 

 

 

 

 
 

 

Test Case for the numerical solution 
Solve the one dimensional wave equation in the spatial domain of [0, 2*pi] with an 

initial 

step function 

condition given by 

U0(x,0) = 1 for x  

pi-1 
= 0 otherwise 
Choose 100 grid points and find the wave form at t = 0.2 s. 

Matlab code for the one dimensional wave equation 

% Solves the one dimensional scalar wave equation du/dt + du/dx = 0 

[0,2*pi] 
% Using LAX METHOD 
clc; 
clear all; 
t0 = 0; 
tf = 1; 
M = 100; % number of points in x 

direction 

N = 100; % number of points in y 

direction 

% define the mesh in 

space 

dx =2*pi/M; 

x = 0:dx:2*pi; 

% define the mesh in 

time 

dt = (tf-t0)/N; 

t = t0:dt:tf; 

% calculate value for 

lamda 
c = 1; 
lambda = c*dt/dx 
display('lambda should be less than 1 for stability:') 

% choose the wave number of the initial data and give its decay rate 

u0 = x<=(pi-1); 

u = zeros(M+1,N+1); 

u(:,1) = u0; 



Dept of ANE CA Lab Manual 

MRCET UGC Autonomous Page 40 

 

 

 

% Implement the time marching Lax scheme: 

for n=1:N 

for i=2:M 

u(i,n+1) = (u(i+1,n)+u(i-1,n))/2-(lambda/2)*(u(i+1,n)-u(i-1,n)); 

end 

% Introduce exact values at the endpoints. 

u(1,n+1)=1; 

u(M+1,n+1)=0; 
end 

% plot the result in 21 intervals 

for j=0:20 

plot(x,u(:,1+5*j),'LineWidth',2); 
axis([0,2*pi,-0.5,1.5]); 
title('1D wave equation using explicit Lax Method','FontSize',12) 

xlabel('x'); 

ylabel('u'); 
pause(1) 
end 
%plot(x,u(:,101)); 

 

Results: 
 

 

Exercise problems: 

 

 

9.1 Write a Matlab Program to solve one dimensional wave equation using FTCS method. 

 

9.2 Write a Matlab program to find wave propagation at t=0.5 secs 
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10. SOLUTION FOR THE ONE DIMENSIONAL TRANSIENT HEAT CONDUCTION EQUATION 
USING EXPLICIT METHOD (CODE DEVELOPMENT) 

The one dimensional transient (unsteady) heat conduction equation is given as 
 

Where  is the thermal diffusivity 

This equation represents the conduction of heat energy in time and space. Transient 

nature of this equation is represented in the dependence of temperature with 

time as opposed to a steady state condition. 

Numerical Solution 

Method of discretization – finite difference form 

Replace the time derivative with a forward difference expression 

 

Where n is the temporal index and j is the spatial index. 

Replace the second order spatial derivative on the RHS with a central difference formula 
 

 

We then have 
 

 

 

i.e.  (2) 

 

where 

Equation (2) is the final explicit update equation for the one dimensional transient heat 
conduction equation. 

 

Test Case for the numerical solution 
A country rock has a temperature of 300oC and the dike a width of 5m, with a magma 

temperature of 1200oC. Total length of the rock formation is 100m. Initial conditions are 

temperatures of 300oC and 1200oC for the rock and dike respectively. Boundary conditions at 

x = -L/2 and x = L/2 are at 300oC (see figure). Find the temperature distribution after 100 days. 

Use 200 grid points in the x direction with a 1 day time interval. 
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ROCK 

300oC 

DIKE 

1200oC 

ROCK 

300oC 

L 

 

 

Matlab code for the one dimensional transient heat 
conduction equation 

 

% Solves the 1D heat equation with an explicit finite difference scheme 

clear all 
clc 
%Physical parameters 
L = 100; % Length of modeled domain [m] 

Td = 1200; % Temperature of magma [0C] 
Tr = 300; % Temperature of country rock [0C] 
kappa = 1e-6; % Thermal diffusivity of rock [m2/s] 

W = 5; % Width of dike [m] 

day = 3600*24; % # seconds per day 

dt = 1*day; % Timestep [s] 
% Numerical parameters 
nx = 200; % Number of gridpoints in x-direction 

nt = 100; % Number of timesteps to compute 

dx = L/(nx-1); % Spacing of grid 

x = -L/2:dx:L/2;% Grid 

% Setup initial temperature profile 

T = ones(size(x))*Tr; 

T(abs(x)<=W/2) = Td; 
time = 0; 
for n=1:nt % Timestep loop 
% Compute new temperature 

Tnew = zeros(1,nx); 
for i=2:nx-1 
Tnew(i) = T(i) + (kappa*dt/(dx)^2)*(T(i+1)-(2*T(i))+T(i-1)); 

end 

% Set boundary conditions 

Tnew(1) = T(1); 
Tnew(nx) = T(nx); 
% Update temperature and time 
T = Tnew; 

time = time+dt; 
end 

% Plot solution 

plot(x,Tnew); 

xlabel('x [m]') 
ylabel('Temperature[ˆoC]') 
title(['Temperature evolution after ',num2str(time/day),' days']) 

% draw the dike boundaries 

x1 = -2.5; 

x2 = 2.5; 
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y = linspace(300,800); 

% Plot the dike 

boundaries 

hold on 

plot(x1,y, x2, y); 

 

 

Results: 
 

 

 

Exercise problems: 

 

 

10.1 Write a Matlab Program to solve one dimensional heat conduction equation using Lax 

method. 

 

10.2 Write a Matlab program to one dimensional heat conduction equation after 200 days. 
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11. GENERATION OF THE ALGEBRAIC GRIDS 

 
Problem 

Generate an algebraic grid about the upper surface of the airfoil. Points are clustered in j 

direction near the lower surface (using β=1.05 in algebraic grid). Make sure the number of 

points in i and j are flexible. 

 
Introduction, Theory, & Formulations 

A key component of grid generation is the conversion from the physical domain to the 

computational domain, in order to allow for equidistant grid lines in rectangular form. In 

considering a simple two dimensional case, physical coordinates x and y must be converted to 

computational coordinates ξ and η. These computational coordinates are furthermore known 

via the rectangular grid relations. As a result, they must be converted back into physical 

coordinates in order to be of use. For the particular case concerning an airfoil placed on the x 

axis, the following relationships exist: 

 

 

 

As can be seen, Eq. (1) simply states that the x coordinate is the ξ coordinate, as there exists 

no irregularities to alter that axis. The precise relationship in Eq. (2) is due to a required 

clustering near the bottom surface. Here, β represents the clustering parameter, which is given, 

and H represents the total height along the y axis. However, this does not account for the 

geometry of the airfoil, wherein its top surface coordinate is a function of the distance along 

the x axis. The exact equation is: 

 

 

Here, y represents the max height of the airfoil, which would thus be the correspond to y=0 in 

Eq.(2). Height is determined by subtracting this value from maximum height. This allows a 

total expression for the grid y coordinative can be obtained. Note that the x used in Eq. (3) 

assumes 0 at the nose of the airfoil and 1 at the tail. The previous equations effectively define 

all that is needed to generate an algebraic grid. However, this grid will simply be used as a 

starting point for the generation of an elliptic grid. Thus, once x and y are obtained 

algebraically, they will be set as initial conditions for the x and y values used in order to perform 

iterations of the developed finite difference equations. 
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MATLAB code for Algebraic Grid Generation 
 

%Algebraic Grid Generation 

clear all; 
clc; 
%Assign values for t and beta 

t=0.15; 
beta=1.05; 
%Prompt user for number of grid points 

n=input('Enter the number of grid points in the i direction: '); 

m=input('Enter the number of grid points in the j direction: '); 

%Create zeroes matrix for surface 

plots z=zeros(n,m); 

%Assign lengths and values for eta and 

xi 

L=3; 

eta=linspace(0,1,m); 

xi=linspace(0,L,n); 

%x is equal to xi 

X=xi; 

%Find height 

ytop=2; 

for i=1:n 

if X(i) < 1 

ybottom(i)=0; 

elseif X(i) > 2 

ybottom(i)=0; 

else 
x2(i)=X(i)-1; 
ybottom(i)=(t/.2)*(0.2969*x2(i)^.5-0.126*x2(i)-0.3516*x2(i)^2+0.2843*x2(i)^3-0.1015*x2(i)^4); 

end 
H(i)=ytop-ybottom(i); 

end 

%Loop to calculate coordinates 

zeta=beta+1; 

gamma=beta-1; 

alpha=zeta/gamma; 

for i=1:n 
for 

j=1:m 

chi=1- 

eta(j); 

y(i,j)=H(i)*(zeta-gamma*alpha^chi)/(alpha^chi+1)+ybottom(i); 

x(i,j)=X(i); 

end 

end 
surface(x,y,z); 
xlabel ('x'); 
ylabel ('y'); 
title ('Algerbraic Grid'); 
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Discussion of Results 
 

Enter the number of grid points in i direction: 50 

Enter the number of grid points in the j direction: 50 

Algerbraic Grid 

2 
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Figure shows the algebraic grid generation with the growth rate β=1.05 the grids are very fine 

at y=0 and it gets coarser as the y increases. 

The value of growth rate β can be varied and you can see the difference in the growth rate of 

the grid. 

Exercise problems: 
 

 

11.1 Write a Matlab Program to generate algebraic grid over flat plate. 

 

11.2 Write a Matlab program to generate algebraic grid over circle. 

y 
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12. GENERATION OF THE ELLIPTIC GRIDS 

 

 
Problem 

Starting with an algebraic grid, generate an elliptic grid about the upper surface of the airfoil. 

Points are clustered in j direction near the lower surface (using β=1.05 in algebraic grid). 

Make sure the number of points in i and j are flexible. 

Using a predetermined algebraic grid, an elliptic grid can be generated in order to fine 

tune the results for airfoil flow. Coding an algebraic grid necessitates an accounting for 

the geometry of the airfoil, as well as clustering via appropriate equations. Once these issues 

are addressed, partial differential equations can be utilized in order to generate an elliptic grid. 

 
Introduction, Theory, & Formulations 
A key component of grid generation is the conversion from the physical domain to 

the computational domain, in order to allow for equidistant grid lines in rectangular form. 

In considering a simple two dimensional case, physical coordinates x and y must be converted 

to computational coordinates ξ and η. These computational coordinates are furthermore 

known via the rectangular grid relations. As a result, they must be converted back into 

physical coordinates in order to be of use. For the particular case concerning an airfoil placed 

on the x axis, the following relationships exist: 

 

 

 

 

 

 

 

As can be seen, Eq. (1) simply states that the x coordinate is the ξ coordinate, as there 

exists no irregularities to alter that axis. The precise relationship in Eq. (2) is due to a required 
clustering near the bottom surface. Here, β represents the clustering parameter, which 

is given, and H represents the total height along the y axis. However, this does not account 
for the geometry of the airfoil, wherein its top surface coordinate is a function of the 

distance along the x axis. The exact equation is: 

 

 

Here, y represents the max height of the airfoil, which would thus be the correspond to y=0 in 

Eq.(2). Height is determined by subtracting this value from maximum height. This allows 

a total expression for the grid y coordinative can be obtained. Note that the x used in Eq. 

(3) assumes 0 at the nose of the airfoil and 1 at the tail. The previous equations effectively 

define all that is needed to generate an algebraic grid. However, this grid will simply be used 

as a starting point for the generation of an elliptic grid. Thus, once x and y are obtained 

algebraically, they will be set as initial conditions for the x and y values used in order 

to perform iterations of the developed finite difference equations. 

Two elliptic partial differential equations must be solved in order to fully define the 

desired grid. In doing this, boundary conditions are required. For this case, x and y values 
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along the edges of the defined physical domain will be left in place. These being 

predefined allows all interior coordinates to be developed. The following system of elliptic 

partial differential equations can be used to define the domain: 

 

 

 

Here, the subscripts denote second order derivative of that variable. Notice that these equations 

do not express x and y as dependent variables. Rather, they are treated as the independent 

variables, requiring a transformation. When such a mathematical transformation is preformed 

Eqs. (4) And (5) become, respectively: 

 

 

 

 

 

Where, 

 

 

 

 

 

 

 

 

 

The previously stated equations must all be expressed in terms of finite differences. Once this 

is done, x and y at each grid point can be found through iterations. Expanding Equation (8) 

through (10) explicitly in central space yields: 
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Similarly, Considering the expansion of Eq.(7) and solving it for value of : 

 

Here, the superscript, n, indexes the iteration, where n is the current iteration and n+1 is 

the following iteration. These equations are written this way due to the fact that points above 
and to the right of the point being evaluated are unknown, and, thus, old values must be used. 

The same procedure of finite differencing can be applied to Eqs. (6) and (7). However, results 

from these will be of the same form; that is, only the terms x and y will be different. 
Considering the expansion of Eq. (6) yields: 

 

 

Considering, 

 

 

This equation can then be explicitly solved for the value  which is the 

coordinate of interest. Doing so yields: 

 

 

 

 

 

 

 

 

 

 

 

 

This formula can then be implemented through coding in order to find all values of x. The 

formulation is exactly the same for the y value. Through code, multiple iterations will occur 

until convergence is reached; that is, the desired x values will be found once the difference 

between  and  is below tolerance and the desired y values will be found once 

difference between  and  falls below said tolerance. These values, when plotted, should 

produce an elliptic grid that can be utilized to determine flow within the domain containing the 

airfoil. 
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MATLAB code for Elliptic Grid Generation 

%Elliptic Grid Generation 

Clear all; 
clc; 
%Assign values for t and beta 

t=0.15; 
beta=1.05; 
%Prompt user for number of grid points 
n=input('Enter the number of grid points in the i direction: '); 

m=input('Enter the number of grid points in the j direction: '); 

%Create zeroes matrix for surface 

plots z=zeros(n,m); 

%Assign lengths and values for eta and xi 

L=3; 

eta=linspace(0,1,m); 

xi=linspace(0,L,n); 

%x is equal to xi 

X=xi; 

%Find height 

ytop=2; 

for i=1:n 

if X(i) < 1 

ybottom(i)=0; 

elseif X(i) > 2 

ybottom(i)=0; 

else 
x2(i)=X(i)-1; 
ybottom(i)=(t/.2)*(0.2969*x2(i)^.5-0.126*x2(i)-0.3516*x2(i)^2+0.2843*x2(i)^3-0.1015*x2(i)^4); 

end 
H(i)=ytop-ybottom(i); 

end 

%Loop to calculate coordinates 

zeta=beta+1; 

gamma=beta-1; 

alpha=zeta/gamma; 

for i=1:n 

for 

j=1:m 

chi=1- 

eta(j); 

y(i,j)=H(i)*(zeta-gamma*alpha^chi)/(alpha^chi+1)+ybottom(i); 

x(i,j)=X(i); 

end 

end 

 

%Elliptic initial conditions 

xold=x; 
yold=y; 
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%Calculate computational step sizes 

delta_eta=1/(m-1); 
delta_xi=L/(n-1); 
dx=1; %Conditions to start loop 

dy=1; %Conditions to start loop 

%Assign tolerance value 

tol=.0001; 

%Nested loop to determine elliptic grid 

xdiff=0; 

ydiff=0; 
count=0; 

while dy > tol || dx > tol 

for i=2:n-1 
for j=2:m-1 
a1=(xold(i,j+1)-x(i,j-1))/(2*delta_eta); 
a2=(yold(i,j+1)-y(i,j-1))/(2*delta_eta); a=a1^2+a2^2; 
c1=(xold(i+1,j)-x(i-1,j))/(2*delta_xi); 
c2=(yold(i+1,j)-y(i-1,j))/(2*delta_xi); c=c1^2+c2^2; 
b=a1*c1+a2*c2; 
alpha=a/delta_xi^2; 

beta=-2*b/(4*delta_xi*delta_eta); gamma=c/delta_eta^2; theta=1/(2*alpha+2*gamma); 

phi_1=beta*(xold(i+1,j+1)-xold(i+1,j-1)-xold(i-1,j+1)+x(i-1,j-1)); 

x(i,j)=theta*(alpha*(xold(i+1,j)+x(i-1,j))+gamma*(xold(i,j+1)+x(i,j-1))+phi_1); 
xdiff=x(i,j)-xold(i,j)+xdiff; 
phi_2=beta*(yold(i+1,j+1)-yold(i+1,j-1)-yold(i-1,j+1)+y(i-1,j-1)); 

y(i,j)=theta*(alpha*(yold(i+1,j)+y(i-1,j))+gamma*(yold(i,j+1)+y(i,j-1))+phi_2); 

ydiff=y(i,j)-yold(i,j)+ydiff; 

end 
end 
dx=xdiff; dy=ydiff; xdiff=0; 

ydiff=0; 
xold=x; 
yold=y; 
count=c 
ount+1; 
end 

fprintf('The solution took %i iterations to converge. \n \n', count); 

surface(x,y,z); 
xlabel ('x'); 
ylabel ('y'); 
title ('Elliptic grid over an Airfoil'); 
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Result and Discussion 

In the plot of an Elliptical, the Grid lines have been smoothed out due to the elliptic equations, 

eliminating extreme jaggedness resulting from the algebraic grid. This would ensure a more 

accurate flow model. 

Enter the number of grid points in the i direction: 50 

Enter the number of grid points in the j direction: 50 

The solution took 2434 iterations to converge. 

 
Elliptic grid over an Airfoil 

 

Overall, an elliptic grid was shown to provide desired results for discretization. It succeeded in 

smoothing out otherwise rough edges created through algebraic grid generation. At the same 
time, the algebraic grid provided a suitable starting point for the generation of the elliptic grid. 

0 0.5 1 1.5 

x 

2 2.5 3 
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VIVA QUESTIONS: 

1. Define CFD? 

2. What are the three major steps of CFD? 

3. What are the governing equations of CFD? 

4. What is meant by Discretization? 

5. Which type of Discretization is used in CFD? 

6. Difference between forward and backward differencing scheme? 

7. What is Explicit method and Implicit method? 

8. What is LAX method? 

9. What is a stability criterion? 

10. What is thermal diffusivity? 

11. Define Grid? 

12. Difference between Structured and Unstructured grid? 

13. What is meant by Grid Independence study? 

14. What is linspace command in MATLAB? 

15. How to give titles to X and Y axis of a graph? 

16. How to create Hybrid mesh in ICEM? 

17. How to create structured grid in ICEM? 

18. What is the importance of Body point in ICEM? 

19. How to define material properties in CFX or FLUENT? 

20. What is meant by convergence criteria? 

21. How to define supersonic inlet conditions in CFX? 

22. What is Grid adaption technique? 

23. What is meant by parallel and serial processing? 

24. In how many ways CFD results can be presented? 

25. How to define formulas in CFD Post? 

26. What are the causes for reverse flow or diverged flow during CFD iterations? 

27. What are the relaxations factors in FLUENT? 

28. What is courant number and how does it affects the solution? 

29. What are the different types of turbulence models in CFD? 

30. Difference between free slip and no-slip conditions? 
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